Overview
While trying to access Exinda WebUI, you are not able to log in with Your session is no longer valid
error.
You have tried to reset the browser and tried to login from multiple systems and devices. However, login access via the Exinda device's CLI is still possible.
This might happen due to disabled Web Session Manager (wsmd) and HTTPD (Apache) processes.
This article provides details on how to resolve GUI accessibility issues by restarting the necessary Web services.
Important: the session error might occur before and after entering Exinda username/password.
Prerequisites
- Admin access to the Exinda WebUI
- Admin access to the Exinda CLI
- Jboss was already restarted
- You should have the Restricted Commands License Active (This is required to run Linux commands on your Exinda device. If it is not active you can open a Support Ticket)
Diagnosis
The very first step you need to perform is to validate that the root cause of this is the Web Processes' failures, in order to do this you need to:
- Log in to your Exinda CLI
- Type in the following commands:
en
_shell
- Navigate to the /var/log/ directory with the following command
cd /var/log/
Tip: verify the current working directory by usingpwd
command. - Once in that directory, you need to look for the messages file and open it with a text editor (for this example, we will be using vi)
vi messages
- Inside the file, you need to look for the following lines
[wsmd.NOTICE]: session 1: could not accept due to too many fds, disabling listening
or
[web.ERR]: Error code 14001 (unexpected NULL)
[web.ERR]: Request handler failed with error code 14002: assertion failed
This would mean the root cause of Exinda WebUI issues is Web daemons are disabled or encountered errors.
Important Notes and Tips
- You can also grep the error instead of opening the file by typing the following command
grep -i wsmd.NOTICE messages
orgrep -i web.ERR messages
- To show continuous log generation in real-time:
en sh log cont
- If you are not able to find such error messages in the logs, that means the root cause is different, you can open a Support Ticket and ask for assistance
Solution
- Log in to your Exinda CLI
- Type in the following commands:
en
_shell
- Restart wsmd by executing the following command:
pm process wsmd restart
- Restart HTTP daemon:
pm process httpd restart
Note: The WSMD and Apache services can only be restarted using the pm commands in CLI. They do not cause any impact to the traffic shaped by the Exinda as it's only applicable for the web interface. - Restart database:
pm process mysqld restart
- Restart JBoss:
en
conf t
service jboss restart
- If you are not using the latest version of ExOS, please upgrade to ensure better performance. Please see the article Upgrading the Exinda Firmware and the latest Exinda 7.4.13 Release Notes
Testing
You will be able to log back into the Exinda WebUI