Overview
In the Exinda firmware, the kernel logs generated by a reboot are located in the standard Exinda log. During the reboot process, before everything is initialized, you may observe the bellow logging message:
mpmd[204]: [mpmd.ERR]: mdc_send_mgmt_msg_raw(), mdc_main.c:117, build 1: Error code 14002 (assertion failed) returned.
Root Cause
When Exinda reboots, the primary management process (mgmtd) needs to start up and initialize. This management process is central, and all other processes require communication to it to function correctly. The mgmtd process restarts with the device, but depending on the device's load, hardware, and the traffic passing through, it can take a different amount of time for it to come up.
This error message is generated when another process is attempting to communicate with the management process while it is not ready to respond. The generated error message is an 'assertion failed,' meaning that a condition that the second process assumed as true was false instead.
Information
- During a reboot, a few occurrences of this error is no means for concern.
- If it is repeated more than a few times (ten or more), it might indicate a problem with the central management process (this includes standard operation as well).
- If this error occurs during standard operation, it may suggest that mgmtd is under extreme stress.