Summary
When tried to generate report and sent it out via email, there's an error message: file/temp/exreport_(devicename and date&time).pdf does not exist or is not a regular file ...Overview
When you try to email the report, the following message appears.Error: File /tmp/pdfreport.pdf does not exist or is not a regular file
The report that is sent out has nothing in it (0 kb) and damaged. Adobe is unable to open it.
Cause
When generating report, the process nodepdf in the appliance is listening on port 1337 and the following lines are expecting:-info: HTTP server listening on port 1337 at localhost.
tcp 0 0 0.0.0.0:1337 0.0.0.0:* LISTEN 2296/node
Workaround
1. Are there any notifications regarding /var partition utilization is high?2. If no, please login Web GUI by a local admin account and try to generate PDF report again.
3. If it is still not working, go to check the log and find some lines like these:
Mar 8 09:57:20 EXINDA mgmtd[2663]: [mgmtd.NOTICE]: Launching PDF generation script.
Mar 8 09:57:20 EXINDA wsmd[3033]: [wsmd.NOTICE]: User admin (System Administrator) logged into Web UI from localhost
Mar 8 09:57:21 EXINDA wsmd[3033]: [wsmd.NOTICE]: User admin (System Administrator) from localhost logged out of Web UI
4. Open an ssh session to your appliance and check if http redirect been enabled.
## Network management configuration
# web http redirect
Resolution
This issue has been fixed in 7.4.3. Upgrading the firmware to this firmware will solve the problem.Defect ID
D-05260Additional Information
This defect has been fixed in firmware version 7.4.3 which allows to run reports with HTTP redirect.Defect URL
https://www4.v1host.com/Exinda/defect.mvc/Summary?oidToken=Defect%3A179904Internal Notes
Steps to troubleshooting:1. Check /var partition utilization and permission for the folder /var/tmp
2. Login Web GUI by a local admin account and try to re-adding a report, or adding a new report.
3. Restarted the nodepdf process and try to generate it again.
4. Ask for a sysdump, then check the pdf_server.log files, is it blank? In normal, the following lines are expecting :
-info: HTTP server listening on port 1337 at localhost.
-info: Debug mode is OFF
5. Check if http redirect been enabled and remove the web http redirect under the command line can fix this issue.
no web http redirect