Overview
Exinda Warning "System Disk Full".
Symptoms:
- Cannot upgrade firmware.
- Monitoring data is not available.
- System is slow
Root Cause
- Dump/Garbage files created due to a process not being handled properly.
- Process Failure.
- Hardware Reboot/Firmware Upgrade.
- Version 7 creating multiple copies of Jboss instances.
Resolution
-
Go to System > Setup > Storage and format the partition for which the error has triggered.
-
If you cannot find the partition under warning then please contact Exinda support.
-
Try and delete all sysdumps, snapshots and TCP Dumps.
Note: Please contact Exinda Support if the disk is still not free.
Additional Notes
To find files which might be taking up disk space check the root directory space using "df -h"
. Find out which partition is almost full. Generally, it is /var
.
You can remount /var
onto a temporary folder somewhere and then try and find out what is filling it up.
Steps to mount
cd /tmp
mkdir remount
mount /dev/sda9 /tmp/remount
and then to unmount the partition after looking for the biggest files in it use - umount remount
To check the size of the biggest files mounted in /var
use
du -x /var | sort -rn | head -20